best c# pdf library : Active links in pdf control SDK system azure wpf asp.net console acrobat-9-troubleshooting33-part2070

332
Last updated 11/3/2015
• Run the AcrobatPatchApplication.exe file in silent mode by specifying the -silent flag on the command line.
Example: <path of AcrobatPatchApplication.exe> -silent
A log is created in the temp directory (%temp%) with the name AcroPatchApplication942.log. Changes take effect only 
after you restart your computer.
When run in silent mode, all dialog boxes are suppressed. No success dialog with restart recommendation is shown.
Solution 3: Replace the installed manifest file with an updated version.
Download the Adobe.Acrobat.Dependencies.manifest file by right-clicking the following link and choosing Save Target 
As or Save Link As from the context menu. 
Adobe.Acrobat.Dependencies.manifest 
Right-click the downloaded manifest file and choose Copy from the context menu.
Using Windows Explorer, navigate to the following folder:
• 32-bit Windows: Computer\Local Disk (C:)\Program Files\Adobe\Acrobat 9.0\Acrobat
• 64-bit Windows: Computer\Local Disk (C:)\Program Files (x86)\Adobe\Acrobat 9.0\Acrobat
Right-click and choose Paste from the context menu. Choose Yes to overwrite the old file.
Restart your computer.
Solution 4: Delete or replace the atl.dll file in the Adobe.Acrobat.Dependencies.manifest.
If you are using Windows Vista or Windows 7, edit the file with full administrator privileges. To edit a file with full 
administrator privileges, disable User Account Control (UAC) for the system. See the following knowledgebase 
documents for information about disabling the UAC.
Note: After you have edited the manifest file, re-enable the UAC. 
• Disable User Account Control (UAC) | Windows Vista (kb404888)
• Guided Help: Adjust User Account Control settings in Windows 7
?
Using Windows Explorer, navigate to:
• 32-bit Windows: Computer\Local Disk (C:)\Program Files\Adobe\Acrobat 9.0\Acrobat
• 64-bit Windows: Computer\Local Disk (C:)\Program Files (x86)\Adobe\Acrobat 9.0\Acrobat
Right-click the Adobe.Acrobat.Dependencies.manifest file and open it in Notepad.
Press Ctrl+F and search for “atl.dll” without the quotes.
Delete the line containing atl.dll, close the text editor, and accept the changes.
Restart your computer.
Solution 5: Reset the default e-mail program.
Follow these steps to reset the default e-mail program used by Acrobat.
Choose Start > Default Programs > Set program access and computer defaults > Custom.
Expand Custom and under Choose a default mail program choose Outlook.
Click OK to close the dialog and then try again to attach the e-mail.
Active links in pdf - insert, remove PDF links in C#.net, ASP.NET, MVC, Ajax, WinForms, WPF
Free C# example code is offered for users to edit PDF document hyperlink (url), like inserting and deleting
add url pdf; convert a word document to pdf with hyperlinks
Active links in pdf - VB.NET PDF url edit library: insert, remove PDF links in vb.net, ASP.NET, MVC, Ajax, WinForms, WPF
Help to Insert a Hyperlink to Specified PDF Document Page
convert doc to pdf with hyperlinks; check links in pdf
333
Last updated 11/3/2015
Additional information
If you repair Acrobat 9.4.2, repeat the solutions. The updated Adobe.Acrobat.Dependencies.manifest file is overwritten 
by the original file during the repair. 
Adobe recommends updating to Acrobat 9.4.3 to avoid this issue recurring.
Adobe Approved Trust List update dialog appears | 
Acrobat, Reader
Description
When you use Adobe Acrobat or Reader to open PDF documents that were signed or certified using certificates, you 
see the following message:
"A new security settings update is available from Adobe Systems. Would you like to install it now?" This dialog is a 
trusted Adobe dialog referring to updates to the root certificate list (AATL) in Acrobat or Reader.
Explanation
AATL or Adobe Approved Trust List is a program that allows millions of users around the world to create digital 
signatures. The signatures are trusted whenever the signed document is opened in Adobe Acrobat 9 or Reader 9 or later. 
The list of trusted certificates is updated from time to time in case some certificates have been added, renewed, or have 
expired.
These updates are distinguished from the standard product updates for Acrobat or Reader, which can be triggered by 
choosing Help > Check For Updates.
Related preferences
If you want to check for certificate updates, choose Edit > Preferences > Trust Manager > Click Update Now under the 
section Automatic Updates. The same update dialog box opens. Using this option, the certificate updates are loaded 
from a trusted server.
To enable the automatic update check, choose Edit > Preferences > Trust Manager > Load Trusted Root Certificates 
From An Adobe Server. To enable the automatic check without any notification, deselect Ask Before Installing. 
Assuming that you have enabled the automatic check, the certificate updates are triggered under the following 
conditions:
you open a file that has a digital signature, and
you have never checked for updates before, or
334
Last updated 11/3/2015
you have checked before, but
28 days have elapsed and
there is a new update available
You can select Yes and the trusted certificate list in Acrobat or Reader is updated. If you want to see the trusted list, 
choose Open Adobe Reader > Document > Manage Trusted Identities. In the window that opens, choose Display > 
Certificates. The entire Trusted Certificates list currently installed with your Reader appears.
Enterprise deployment
If you are working in an enterprise environment and want to control these settings for an enterprise deployment, use 
the Customization wizard to activate or deactivate these options.
Additional information
http://help.adobe.com/en_US/Acrobat/9.0/Standard/WS8084ADD0-83CB-43fe-B3CC-0D9AF9224C8C.w.html 
AIR application doesn't display PDF file while using 
Adobe Reader/Acrobat 9.2 on Windows
Issue
Adobe AIR applications using version 9.2 of Adobe Reader and Acrobat do not display a PDF file.
Note: This issue occurs on the Windows operating systems only.
Solution
Download and install the latest version  (AIR 1.5.2.8900) of the Adobe AIR runtime. The updated version of AIR 
1.5.2.8900 includes a fix that addresses this issue. Since this issue does not impact Mac or Linux users, those users can 
continue using AIR 1.5.2.8870 (1.5.2.8900 is only available for Windows operating systems).
To determine the version number of Adobe AIR installed on your system on Windows operating systems: 
Launch the Add or Remove Programs system utility on Windows (usually listed in the Control Panel).
Select Adobe AIR.
Click the "Click here for support information" link. A dialog opens that displays the complete version number.
If the version number of Adobe AIR is 1.5.2.8870 or earlier, download the latest version  of the Adobe AIR runtime.
335
Last updated 11/3/2015
Additional Information
This issue appears when both Adobe AIR 1.5.2.8870 (or earlier versions) and Reader/Acrobat 9.2 are installed on a 
user's system running Windows operating systems.
For developers of Adobe AIR applications that include PDF content, install the latest version  of the AIR SDK.
To manually overlay a newer version of the AIR SDK using Flex Builder, see " How to overlay AIR SDK for use with Flex 
SDK" in the Adobe AIR release notes.
Crash on close | Preflight panel access
Acrobat X Professional 10.1.2 crashes when you exit it after accessing the Preflight panel.
Solution 1: Update to Acrobat X Professional 10.1.3
The free 10.1.3 update to Acrobat X Professional addresses this issue. You can install it automatically from within 
Acrobat.
Open Acrobat X Professional.
Choose Help > Check for Updates.
Acrobat installs the update automatically.
If you prefer, you can download and install the update yourself from this page: 
• Acrobat updates (for Windows).
Solution 2: Install the following patch for Acrobat X Pro 10.1.2 
This solution isn't required if you update to Acrobat X Pro 10.1.3.) Download and apply the fix file below:
Acrobat X Professional (10.1.2)
Log in to your computer as an Administrator.
Click the link to download the AdobeAcrobatPatch10.1.2_cpsid_92893.zipfile.
Unzip the file to extract the executable AdobeAcrobatPatch10.1.2_cpsid_92893.exe.
336
Last updated 11/3/2015
Do one of the following to run the AdobeAcrobatPatch10.1.2_cpsid_92893.exe file:
• Double-click the AdobeAcrobatPatch10.1.2_cpsid_92893.exe file.
• Run the AdobeAcrobatPatch10.1.2_cpsid_92893.exe file in silent mode by specifying the -silent flag on the
command line. Open the command prompt As Administrator to avoid the UAC prompt dialog.
Example: <path to AdobeAcrobatPatch10.1.2_cpsid_92893.exe> -silent 
Once the process is completed, you receive a prompt stating the result of the operation.
Note: When run in silent mode, all dialog boxes are suppressed. No success message or error message appears. 
A log is created in the temp directory (%temp%) with the name AcroPatchApplication1012.log. (The changes 
sometimes only takes effect only after you restart your computer.) 
Additional information
• A Standard user on Vista or Windows 7 can apply the patch upon supplying the relevant credentials upon receiving 
the UAC prompt.
• A Standard user on Vista or Windows 7 can apply the patch upon supplying the relevant credentials upon receiving 
the UAC prompt.
• To prevent any probable errors while running the executable, close any instances of Acrobat/Reader on your syst t em.
Acrobat X context menu missing | 64-bit Windows 7
Issue
After you install the Acrobat X 10.0.1 update on 64-bit Windows 7, the Acrobat context menu choice is missing from 
Windows Explorer. 
Solution 1: Register Context Menu DLL
Choose Start > All Programs.
Click Accessories.
Right-click Command Prompt and choose Run As Administrator from the context menu.
Click Yes on the user Account Control dialog box.
Type the following line and press Return.
For Acrobat 10 and 64-bit Windows Operating System: regs vr32 "C:\Program Files (x86)\Adobe\Acrobat 10.0\Acrobat 
Elements\ContextMenu64.dll"
For Acrobat 10 and 32-bit Windows Operating System: regsvr32 "C:\Program Files\Adobe\Acrobat 10.0\Acrobat 
Elements\ContextMenu32.dll" 
For Acrobat 9 and 64-bit Windows Operating System: regsvr32 "C:\Program Files (x86)\Adobe\Acrobat 9.0\Acrobat 
Elements\ContextMenu64.dll" 
337
Last updated 11/3/2015
For Acrobat 9 and 32-bit Windows Operating System: regsvr32 "C:\Program Files\Adobe\Acrobat 9.0\Acrobat 
Elements\ContextMenu32.dll" 
Solution 2: Add Acrobat’s context menu key under Approved folder in 
window’s registry
Check if a string with value data “Adobe.Acrobat.ContextMenu” is not blocked by windows machine.
String Path: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell 
Extensions\Blocked with a value data: Adobe.Acrobat.ContextMenu
If the string is present under the window’s blocked keys, just remove this particular string from above location of 
affected machine and then restart.
The above string should be under the Approved folder only. 
Acrobat prompts for admin login when you start from a 
non-admin account (Acrobat 9.0 on Mac OS X)
Issue
When you start Acrobat 9.0 on Mac OS X (10.x) as a non-admin user or an admin user other than the user used to 
install Adobe Acrobat 9.0, you are prompted for a username and password.
Solution
Do one of the following: 
Solution 1: Pressing the "Cancel" button when this prompt is presented will cause the prompt to not present itself upon 
subsequent launches of the application.
Solution 2: Provide the username and password of an administrative user. 
Solution 3: Log into the machine as the same account that was used to install Acrobat 9.0. 
Adobe is aware of this issue and looking for a more permanent solution. 
Acrobat product interoperability: Install and remove 
Acrobat and Adobe Reader (8.x on Windows)
What's covered
• Coexisting installations
• Version interoperability
338
Last updated 11/3/2015
• Upgrade eligibility
Coexisting installations
Although you can install Adobe Acrobat 8.0.x or Adobe Reader 8.0 on a computer that contains an installation of 
previous Acrobat versions, it is not recommended. Acrobat 8.0.x Professional and Acrobat 8.0.x Standard use the 
Acrobat 8.0.x version of PDFMaker and Adobe PDF printer. When two or more versions of Acrobat are installed on the 
same computer, removing one version of Acrobat may disable functionality. 
If two versions of Acrobat are installed on the same computer, only the Acrobat 8.0.x version of PDFMaker and Adobe 
PDF printer will be used, although conflicts may occurs if multiple version PDFMaker files are attempting to load. 
When multiple versions of Acrobat exist on a machine, the running version will be used to display PDF files regardless 
of the preferences. 
Removing previous versions of Acrobat or Adobe Reader after you install a more recent version can disable 
functionality. Repair the current version of Acrobat after removing the previous version. If the repair process does not 
restore all functionality, reinstall the current version. 
Note: Adobe Technical Support does not recommend having multiple versions of Acrobat or Adobe Reader installed 
on the same machine. Acrobat and Adobe Reader have numerous components that have similar functionality and can 
cause conflicts on a machine. The most prevalent among these conflicts involves the plug-ins for rendering PDF files 
in the browser, PDFMaker inside of Office Applications, and the Adobe PDF printer. Using the Version Interoperability 
table below, remove all versions of Acrobat and Adobe Reader, and then install the current version. 
Version interoperability
This chart shows what will happen if you install Adobe Acrobat 8.0.x when the computer already has Acrobat or Adobe 
Reader installed. 
339
Last updated 11/3/2015
• Allowed indicates that this state will function and should not generate any error messages.
• Replace indicates that the new version will replace the original version with no option to remove the original
version.
• Repair indicates that you are trying to install a version of Acrobat or Adobe Reader that is already installed on yo o ur
computer, and the installer allows you to modify, repair, or remove the program.
• Recommended Removal indicates that you should cancel the installation of Acrobat 8.0.x and remove the older
version, reboot, and then install Acrobat 8.0.x
Product
Standard 8.0
Professional 8.0
Acrobat 8.0 Trial
Adobe Reader 8.0
Notes
Acrobat Reader 
5.0.5 or earlier
Allowed 
Allowed 
Allowed 
Uninstalls previous 
version. 
Browser uses version 
8. 
Adobe Reader 6.0
Allowed 
Allowed 
Allowed 
Uninstalls previous 
version. 
Browser uses version 
8. 
Adobe Reader 7.0
Allowed 
Allowed 
Allowed 
Unstalls previous 
verison. 
Browser uses version 
8. 
Adobe Reader 8.0
Allowed 
Allowed 
Allowed 
Repair 
Reader will prompt 
for browser version. 
Elements 6.0
Recommended Auto 
Removal 
Recommended Auto 
Removal 
Recommended Auto 
Removal 
Allowed 
Installed reader 
controls browser. 
Elements 7.0
Recommended Auto 
Removal 
Recommended Auto 
Removal 
Recommended Auto 
Removal 
Allowed 
Installed reader 
controls browser. 
Acrobat 5.x full
Recommended 
Removal. 
Recommended 
Removal. 
Recommended 
Removal. 
Allowed 
Browser uses version 
8. 
Acrobat 6.0 
Standard
Recommended Auto 
Removal 
Required Auto 
Removal 
Required Auto 
Removal 
Allowed 
Reader will prompt 
for browser version. 
Acrobat 7.0 
Standard
Recommended Auto 
Removal 
Recommended Auto 
Removal 
Recommended Auto 
Removal 
Allowed 
Reader will prompt 
for browser version. 
Acrobat 8.0 
Standard
Repair 
Recommended Auto 
Removal 
Recommended Auto 
Removal 
Allowed 
Reader will prompt 
for browser version. 
Acrobat 6.0 
Professional
Recommended Auto 
Removal 
Required Auto 
Removal 
Required Auto 
Removal 
Allowed 
Reader will prompt 
for browser version. 
Acrobat 7.0 
Professional
Recommended Auto 
Removal 
Recommended Auto 
Removal 
Recommended Auto 
Removal 
Allowed 
Reader will prompt 
for browser version. 
Acrobat 8.0 
Professional
Manually Remove 
Repair 
Repair 
Allowed 
Reader will prompt 
for browser version. 
Creative Suite 1.0
Recommended Auto 
Removal 
Recommended Auto 
Removal 
Recommended Auto 
Removal 
Allowed 
Reader will prompt 
for browser version. 
Creative Suite 1.3
Manually Remove 
Recommended Auto 
Removal 
Recommended Auto 
Removal 
Allowed 
Reader will prompt 
for browser version. 
Creative Suite 2.0
Manually Remove 
Recommended Auto 
Removal 
Recommended Auto 
Removal 
Allowed 
Reader will prompt 
for browser version. 
Acrobat 3D
Recommended Auto 
Removal 
Recommended Auto 
Removal 
Recommended Auto 
Removal 
Allowed 
Reader will prompt 
for browser version. 
Acrobat 3DTrial
Recommended Auto 
Removal 
Recommended Auto 
Removal 
Recommended Auto 
Removal 
Allowed 
Reader will prompt 
for browser version. 
340
Last updated 11/3/2015
• Recommended Auto Removal indicates that you will receive a warning indicating that an older version has been
encountered. You can remove the older version or ignore it and have Acrobat and Adobe Reader coexist.
• Required Auto Removal indicates that you will receive a warning that an older or less functional product has been 
detected. You can remove the less functional product or cancel the installation.
• Manually Remove indicates that you must quit the installer, remove the version of Acrobat or Adobe Reader that is
currently installed, and then install Acrobat 8.0.x.
Upgrade eligibility
The following products do notqualify for an upgrade to Acrobat 8: 
• Acrobat 4.x or earlier
• Acrobat Elements
• Acrobat Business Tools
• Acrobat Approval
• Adobe Reader
• Acrobat Reader 
• Acrobat Reader-Writer
• Acrobat Distiller PE or LE, or any version of Acrobat Distiller that's bundled with Adobe PageMaker or Adobe
FrameMaker
Note: Adobe Designer 6.0 doesn't qualify for Acrobat 8.0.x but does qualify for Designer 7.1. 
Acrobat hangs while scanning | Acrobat 10.1.4 | 
Windows
Issue
Scanning with Acrobat 10.1.4 using any mode (Grayscale or Color or BW) causes Acrobat to hang when scanning is 
about to complete.
Solution
Install the patch for Acrobat and Reader 10.1.4 (Windows only).
Log in to your Windows computer as an Administrator. 
Click the following link to download the patch file: 
AdobeAcrobatReaderPatch10.1.4_3314564.zip
When prompted "Do you want to open or save this file?," click Open.
341
Last updated 11/3/2015
Extract the file. The location varies depending on your operating system and the utility.
Double-click the extracted AdobeAcrobatReaderPatch10.1.4_3314564.exe file to begin the update.
When a prompt notifies you that the update is complete, restart your computer.
Install the patch for Acrobat and Reader 10.1.4 in silent mode (Windows only).
Log in to your Windows computer as an Administrator. 
Click the following link to download the patch file: 
AdobeAcrobatReaderPatch10.1.4_3314564.zip
When prompted "Do you want to open or save this file?," click Open.
Extract the file. 
Open the command prompt "As Administrator." 
Type the path to the patch file executable, and add the -silent flag on the command line. For example: 
AdobeAcrobatReaderPatch10.1.4_3314564.exe -silent
Silent mode supresses all dialog boxes so you do not get a message indicating that the update is complete. The 
executable posts a log file "AcroPatchApplication1014.log" in the temp directory (%temp%).
When the update is complete, restart the computer. 
Use Acrobat forms and form data on the web
Adobe PDF files are usually optimal for online viewing, particularly when they contain forms. Using Acrobat 5.x or 
Acrobat 6.0 Professional, you can create Adobe PDF forms that contain list and check boxes, radio buttons, text fields, 
or buttons that execute specific behavior. For example, a button could send form data to a script on a Web server. (Some 
form of script, or application, must be on the Web server to collect and route the data to another location, such as a 
database.)
You must submit PDF forms from within a Web browser (for example, Netscape Navigator or Microsoft Internet 
Explorer). If you try to submit a PDF form in Adobe Reader , Adobe Reader returns the error "Acrobat Forms: You need 
to be running inside a web browser in order to submit this form."
Documents you may be interested
Documents you may be interested